Back
Maintenance

Release Deployment

Completed 9 Jul at 11:00pm CEST.

Test Spiel Lexikon
Completed

Maintenance completed

Posted 9 Jul at 11:00pm CEST.
Started

We deploy a new release of the application. Short downtimes could occur

Posted 9 Jul at 09:14pm CEST.